OctaFX - News

    OctaFX

    427.25 8.75/10
    88% of positive reviews
    Real

    MetaTrader 5 build 1745 will be the last platform version supporting Microsoft Windows XP/2003/Vista

    Dear Clients!

    Please be informed that MetaTrader 5 build 1745 will be the last platform version supporting Microsoft Windows XP/2003/Vista.

    MetaTrader 5 build 1745 and older versions will continue to work on the above operating systems, but will no longer receive updates. Please notice that Windows 2003, Windows Vista and especially Microsoft Windows XP are outdated operating systems. Platform installers will not run on these operating systems.

    Please notice that the minimum required operating system version for running MetaTrader 5 is Windows 7. However, we strongly recommend using the 64-bit version of Windows 10.

    If you need any help upgrading your MT4 or MT5 terminal, please contact our Support team.

    Thanks for choosing OctaFX as your favourite broker.

    We hope all your trading is smooth and successful.


    To leave a comment you must or Join us


    By visiting our website and services, you agree to the conditions of use of cookies. Learn more
    I agree